LEGO Harry Potter Years 5 to 7 MACOSX-MONEY

MACOSX, Mac OS X Games. March 28, 2012 by Jason.

Lord Voldemort is taking Hogwarts apart brick by brick and it’s up to you to stop him. Build, break and enchant your way through an incredible LEGO adventure set in the Muggle and wizarding worlds.

LEGO Harry Potter: Years 5-7

The battle is building!

Before you download, expand this description to check the system requirements below.

Based on the last three Harry Potter books and final four films, LEGO Harry Potter: Years 5-7 brings encounters with new characters, new challenges and lots more magic as you prepare for the ultimate showdown with Lord Voldemort.

Key Features:
• Experience Harry’s last three years at Hogwarts the LEGO way, with comical re-interpretations of scenes from the last four Harry Potter movies.
• Unlock over 150 playable characters, from old favourites to new additions such as the evil Bellatrix LeStrange and the werewolf Fenrir Greyback.
• Team up to fight the forces of evil in a co-operative mode that lets a second player drop in or out at any time.
• Learn an array of new spells by attending class at Hogwarts and join Dumbledore’s Army to master wizarding duels.
• Explore charming LEGO versions of new locations including Godfric’s Hollow, Grimmauld Place, the Ministry of Magic and even Muggle London.
• Experiment with unpredictable magical items, from the Weasleys’ joke boxes to Hermione’s bottomless handbag and Luna’s SpectreSpecs.
• Use each character’s special abilities to discover hundreds of secrets and rescue Hogwarts students in peril.

Important information regarding LEGO Harry Potter: Years 5-7:
• You can find out more about the game on the LEGO Harry Potter: Years 5-7 mini-site at
• If you encounter problems playing the game, please visit and contact our support team.
• Minimum System Requirements: Processor: 1.4 GHz, RAM: 2GB, Graphics: 128MB, Free Space: 7GB.
• The following graphics cards are not supported: ATI X1xxx series, ATI HD2xxx series, NVIDIA 7xxx series and Intel GMA series.
• The following cards require you to have 4GB of System RAM: NVIDIA 320M, NVIDIA 9400 and Intel HD 3000.



1. Open Finder and go to Applications
2. Right click on LEGO Harry Potter: Years 5-7 and choose 'Show Package Content
3. Go to Contents/Resources and find content.loader
4. Right click on content.loader and choose 'Show Package Content
5. Go to Contents/Resources/MacOS and delete the file named content
6. Copy the file content from to this dir

Additional notes
If the game menu looks wierd you need to change your UI language in OS X to english. This can be done from System Preferences - Language

Download File

Here you can download files online. Unlimited access to all sources file with one click direct download link!
  • Featured link
  • [28-03-2012]
  • SOUL83
  • [13 April 2012 05:34]